Accept Button on Worksheets not Working on Customer Webpage

Incident Report for Leap

Resolved

This incident has been resolved.
Posted May 22, 2026 - 14:43 EDT

Investigating

We are currently investigating this issue.
Posted May 22, 2026 - 12:26 EDT
This incident affected: Leap Essentials & Leap Team (Document Creation and Management).