SalesPro Degraded Performance

Incident Report for Leap

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 14:45 EDT

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 14:40 EDT
This incident affected: SalesPro (Authentication and Account Management, Estimates / Proposals / Contracts, Financing, Leap SecureSign, Price Guide / Materials).