Leap CRM - Degraded Performance

Incident Report for Leap

Resolved

Leap CRM has remained stable since 12:40 PM ET and this incident is now resolved. Thank you for your patience.
Posted Aug 21, 2026 - 16:00 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2026 - 13:07 EDT

Monitoring

We have identified the cause of slow response times and intermittent timeouts in Leap CRM between approximately 12:00 and 12:40 PM ET. The issue was resolved by 12:40 PM ET and performance has returned to normal. We are continuing to monitor.
Posted Aug 21, 2026 - 13:01 EDT

Investigating

Investigating
Posted Aug 21, 2026 - 12:28 EDT
This incident affected: Leap Essentials & Leap Team (Authentication and Account Management, Customer Relationship Management).