Proposals unavailable in SalesPro iOS 2.20 release.
Incident Report for Leap
Postmortem

In iOS version 2.20, we introduced PDFs as a type for contracts and proposals, which lead to an overhaul of the governing system for managing these types.  While reformatting for the new system, we incorrectly duplicated contracts into the proposals view and did not catch that in our testing.  We are instituting better type checking and regression tests as part of our RCA.

Posted Sep 24, 2024 - 16:20 EDT

Resolved
We've heard back from clients that the issue is fully resolved in the 2.20.1 build. Please upgrade from 2.20 if this issue still affects you.
Posted Sep 23, 2024 - 17:10 EDT
Monitoring
SalesPro iOS version 2.20.1 is now available in the store for manual download. Our guidance is that everyone affected by the Proposals bug in 2.20 immediately upgrade to solve the issue. We are continuing to monitor the performance of 2.20.1
Posted Sep 23, 2024 - 16:21 EDT
Identified
We are aware of an issue in our 2.20 release causing mobile app users to have Contracts appearing in the Proposals section of the app, leaving proposals unavailable. We have identified a fix and will work with Apple to expedite a new build. Our guidance at this time is to NOT update to 2.20 manually in the interim. We have proactively reached out to MDM enabled organizations as soon as we were aware to pause rollout. We do not have a reversion build at this time, but will roll forward with a new build ASAP for those affected.
Posted Sep 23, 2024 - 14:19 EDT
This incident affected: SalesPro (Estimates / Proposals / Contracts).